samedi 16 janvier 2016

ESH3: Réparation - "Abandon"

Dernier volet de la saga ESH3, celui de l'abandon et du stockage de l'équipement pour, un jour peut-être, me pencher de nouveau dessus. Les derniers essais étaient pourtant bons, la reprise du réglage du mixer 3 ayant permis de passer la quasi-totalité de la séquence de calibration.

Hélas un fonctionnement erratique est apparu après la fermeture des panneaux supérieur et inférieur et la mise en coffret de l'équipement. Les calibrations passent aléatoirement, le comportement change selon que la référence d'horloge utilisée est interne ou externe, la sélection de la dynamique 20dB conduit parfois à sélectionner l'atténuation maximale. Je soupçonne la présence de mauvais contacts que je n'avais pas identifiés quand l'équipement était ouvert et ne subissait donc aucune contrainte.


J'ai passé trop de temps sur ce dépannage pour continuer sans aucune certitude sur le résultat. La flegme aussi de re-démonter tous les panneaux à la recherche d'une panne aléatoire. Je trouverai peut-être un jour le détail des séquences de la calibration et les valeurs attendues ainsi que des cartes en spare.

Cette aventure m'aura permis de découvrir la complexité de la série des équipements de mesures ESH3 et ESVP, de petites merveilles pour les années 80 dont il vaut mieux qu'ils ne tombent pas en panne. Certaines options prises dans la conception restent pour moi un mystère: pourquoi faire simple quand on peut faire compliqué...

mardi 12 janvier 2016

ENERTEC 6504: Réparation

Vérification de la loi de 'Murphy': mon multimètre de table 'Enertec 6504' ne s'est pas allumé lorsque j'en ai eu besoin comme second instrument de mesure à l'occasion du dépannage de l'ESH3.

Ce dernier étant 'quasiment' fonctionnel j'ai pu trouver les quelques minutes nécessaires pour ouvrir le 6504 et engager les vérifications élémentaires dont celle du fusible d'alimentation. Et celui-ci s'est avéré être coupé.

Cela m'a permis d'étudier la conception de cet appareil datant des années 80 mais aussi de découvrir une substance ressemblant à de l'électrolyte de batterie sur le fond intérieur. L'appareil ayant été acheté d'occasion lors de la liquidation de l'entrepôt 'mesure d'occasion' de la société Electronique-Diffusion, il est fort probable que ce dépôt provienne d'une utilisation antérieure, un bloc batterie pouvant en effet être embarqué dans le boitier.


Ce multimètre est fort bien conçu, facile à démonter et fait appel à des composants classiques pour ce qui concerne la logique de contrôle dont un micro-contrôleur 8049 ainsi qu'un 6805 pour la platine d'extension GPIB.

Le bloc blindé amovible le plus à gauche contient la partie acquisition. Je ne l'ai pas ouvert pour éviter tout déréglage de la calibration, n'ayant aucune notice de réglage et l'appareil fonctionnant parfaitement après le changement du fusible.


dimanche 10 janvier 2016

ESH3: Réparation - "On progresse, mais oui"

La dernière carte a été testée et l'erreur '07' se manifeste toujours. Il y a de quoi désespérer quand toutes les mesures sont conformes à celles indiquées dans le manuel de service lequel est cependant loin d'être exhaustif.

Ont pourtant encore été corrigés quelques problèmes:
 - la tension de pilotage de la mémoire analogique de la chaîne FI censée varier de +9V à -5V ne descendait pas au-dessous de -2V. Cette tension est générée à partir d'un comparateur utilisant un amplificateur opérationnel alimentée en +/-10V avec une diode Zener de 4.7V dans la boucle de rétroaction afin de limiter l'excursion dans la plage négative. La seule solution trouvée pour remédier à ce problème a été de changer cette diode par une Zener de 6.2V. Cette tension pilote en effet de manière indirecte l'atténuateur d'entrée de la FI, atténuateur constitué de diodes PIN. De manière indirecte car une mémoire analogique est interposée qui prend la forme d'un MOSFET dont la gate est chargée par une capacité de valeur assez élevée et de très bonne qualité. La tension de consigne est appliquée sur cette capacité par le biais d'un relais 'reed', l'ensemble étant noyé dans de l'araldite. Les tests menés ont montré que ce système fonctionnait fort bien, sa remise à zéro nécessitant une tension de commande de l'ordre de -4.3V donc bien dans la plage indiquée par le manuel.
- le circuit de réinitialisation du microprocesseur ne fonctionnait pas correctement et avait été temporairement modifié par l'ajout d'un condensateur pour forcer l'état du signal. L'étude du circuit a permis de mettre en cause un transistor intégré dans un circuit en comportant plusieurs. J'ai préféré conserver ce circuit que je n'ai pas en stock, et difficile à trouver, en ajoutant un circuit spécialisé, un MAX707. La modification est réversible et garantie maintenant une remise à zéro parfaite.


Pour l'anecdote, la calibration ne fonctionnait plus du tout après réinstallation de l'alimentation et j'ai mis un certain temps pour trouver de l'origine du dysfonctionnement: l'un des fils alimentant directement la platine de pilotage de l'atténuateur s'était dessoudé. La chose étant résolue et l'équipement pouvant être considéré comme totalement fonctionnel pour la partie réception - j'écoute en ce moment même 'Space Oddity' diffusé en onde moyenne, en hommage à David Bowie, par la BBC - j'ai pu commence à étudier plus sérieusement le déroulement de la phase de calibration totale.

Non décrite dans les manuels en ma disposition, celle-ci semble se dérouler ainsi:
1- test rapide des 4 filtres en mode linéaire (AV) et dynamique de 20dB,
2- calibration de la chaîne FI via les filtres 10Khz et 0.5Khz en mode CISPR avec une dynamique de 20dB et une atténuation sur l'étage d'entrée de 50 puis 60 et enfin 70db,
3- calibration de la chaîne FI via les quatre filtres en mode linéaire avec une dynamique de 20dB et une atténuation sur l'étage d'entrée de 30 puis 40 et enfin 50db,
4- calibration de la chaîne FI via les quatre filtres en mode linéaire avec une dynamique de 40dB et une atténuation sur l'étage d'entrée de 30 puis 40 et enfin (0db,
5- calibration de la chaîne FI via les quatre filtres en mode linéaire avec une dynamique de 60dB et une atténuation sur l'étage d'entrée de 30 puis 40 et enfin 50db.

Les deux premières étapes se déroulent correctement, la troisième génère une erreur 07, la quatrième passe parfois et la cinquième génère aussi une erreur 07. J'ai pu remarquer qu'après le lancement du test, le récepteur reste en mode A0 quand pourtant le mode A3 est sélectionné. Le changement de la sélection du filtre corrige le problème. Est-ce lié au défaut de calibration ou à un bogue du firmware ?

Dans tous les cas, le problème réside bien dans la chaîne FI: son atténuateur à diodes PIN et sa commande via la mémoire analogique, l'amplificateur logarithmique et la ribambelle d'amplificateurs opérationnels gérant les trois gains de 20, 30 et 40dB ainsi que le filtrage du signal. J'ai pourtant testé chaque élément et la qualité de la réception confirme un fonctionnement correct. Je vais devoir étudier de nouveau toute la chaîne pour trouver l'élément perturbateur, lequel doit obligatoirement se situer hors de la chaîne de réception celle-ci fonctionnant parfaitement.

A suivre...